!!

Not Registered?

Welcome!  Please register to view all of the new posts and forum boards - some of which are hidden to guests.  After registering and gaining 10 posts you will be able to sell and buy items on our N'porium.

If you have any problems registering, then please check your spam filter before emailing us.  Hotmail users seem to find their emails in the Junk folder.


Thanks for reading,
The NGF Staff.

Author Topic: Insecure connection?  (Read 542 times)

0 Members and 1 Guest are viewing this topic.

Offline GrahamB

  • Trade Count: (0)
  • Full Member
  • ***
  • Posts: 1237
  • Country: gb
  • Gender: Male
    • Awards
Insecure connection?
« on: August 21, 2018, 08:29:15 AM »
My web browser is telling me that my connection to this forum is not secure. I'm using Google Chrome.

I don't think it did this before I went on holiday. Should I be worried?

Offline Fardap

  • Trade Count: (0)
  • Full Member
  • ***
  • N Gauge Society Number: 26027
  • Posts: 271
  • Country: gb
  • Gender: Male
    • Twitter
    • Awards
Re: Insecure connection?
« Reply #1 on: August 21, 2018, 08:39:09 AM »
Is odd as it says the SSL certificate is okay, I use edge and is okay on there but if I open Chrome then the site looks okay on a non secure HTTP:// connection but if you go to an HTTPS:// connection the page doesn't render correctly, it looks like a lot of text links. Firefox behaves the same if you try the HTTP v HTTPS.
 EDGE seems to be okay with either version...

The only reason to need a secure connection really is for transactional sites (payments etc.) I know that Chrome has recently tightened up its SSL treatment so maybe is connected to that?

One for the admins I think as is site/browser compatability...

Offline MJKERR

  • Trade Count: (+3)
  • Full Member
  • ***
  • N Gauge Society Number: X23832
  • Posts: 1498
  • Country: gb
    • Awards
Re: Insecure connection?
« Reply #2 on: August 21, 2018, 08:40:10 AM »
This is due to entering a password
This website has still not been updated with a SSL Certificate by default
« Last Edit: August 21, 2018, 08:41:23 AM by MJKERR »

Offline Tank

  • Administrator
  • Trade Count: (+30)
  • Full Member
  • *****
  • Posts: 7581
  • Country: gb
  • Gender: Male
    • Awards
Re: Insecure connection?
« Reply #3 on: August 21, 2018, 09:23:49 AM »
Apologies, it is on the To Do List.  The site does have a valid certificate, but I haven't changed over to https.

Offline Dalek

  • Trade Count: (0)
  • Full Member
  • ***
  • N Gauge Society Number: 24836
  • Posts: 347
  • Country: scotland
  • Gender: Male
    • Awards
Re: Insecure connection?
« Reply #4 on: August 21, 2018, 01:01:23 PM »
Apologies, it is on the To Do List.  The site does have a valid certificate, but I haven't changed over to https.


From July 25th onwards, if your site contains form elements (such as a sign up form, login form etc), and isnít on HTTPS, Chrome will alert the user to your site being insecure.

@Tank  can you let me know how smoothly your change over goes please as i have to do this to a forum i look after that uses the same software as this one.  :thumbsup:

Craig

Offline mickster04

  • Trade Count: (0)
  • Full Member
  • ***
  • N Gauge Society Number: 26540
  • Posts: 519
  • Country: nz
  • Gender: Male
  • The sing of the rails, music to my ears
    • Ebay
    • Facebook
    • Google+
    • Twitter
    • YouTube
    • Links to mikes online presense
    • Awards
Re: Insecure connection?
« Reply #5 on: August 22, 2018, 03:25:33 AM »
It might also be that peoples avatars are being loaded over http when the rest of the website is sources from https. so chrome warns you that the images you see might not be the ones that the website intended to send you. once the team get the entire site using https only the warning will go away.

 

Please Support Us!
January Goal: £60.00
Due Date: Jan 31
Total Receipts: £125.00
Above Goal: £65.00
Site Currency: GBP
208% 
January Donations

anything
SimplePortal 2.3.5 © 2008-2012, SimplePortal