!!

Not Registered?

Welcome!  Please register to view all of the new posts and forum boards - some of which are hidden to guests.  After registering and gaining 10 posts you will be able to sell and buy items on our N'porium.

If you have any problems registering, then please check your spam filter before emailing us.  Hotmail users seem to find their emails in the Junk folder.


Thanks for reading,
The NGF Staff.

Author Topic: MX617  (Read 172 times)

0 Members and 1 Guest are viewing this topic.

Offline Graham

  • Trade Count: (0)
  • Full Member
  • ***
  • N Gauge Society Number: 20459
  • Posts: 394
  • Country: au
  • Gender: Male
  • Modelling modern image
    • Awards
MX617
« on: April 02, 2019, 08:57:34 AM »
All,
Just received a parcel of the MX617's and appear to have a problem, I have tried 3 so far and all are displaying the same issue, so I am wondering if I have done something wrong or if I have just got a bad batch.

I installed the first decoder in a Farish Class 60, put it onto the track with DC power to test and whilst the lights came on nothing else happened. So I then thought maybe it needs programming first so took off the DC track and put it onto the DCC track where again the lights would work on address 03 but nothing to the motor.

I then tried a 2nd decoder in another Class 60 with the same result, on both units I then put the blanking plate back and all worked fine on DC. I then tried a 3rd one from the shipment in both class 60s with the same result, so I got anther loco out which had the MX622 installed, tried it on the test tracks with all working fine. I then removed the MX622 and placed it in both the locos where I had tried installing the MX617s, again with all working fine.

So the question I have is where to from here, is it something I am doing wrong, is there a trick to the MX617's?

any pointers gratefully received.
cheers
Graham
« Last Edit: April 02, 2019, 08:58:37 AM by Graham »

Offline Steven B

  • Trade Count: (+1)
  • Full Member
  • ***
  • N Gauge Society Number: 12107
  • 2mm Association Number: 4196
  • Posts: 580
  • Country: gb
    • NGS Yorkshire Area Group
    • Awards
Re: MX617
« Reply #1 on: April 02, 2019, 09:15:11 AM »
The MX617 is an updated version of the MX622 so should work in the same way.

Have you got a different class of loco you could try them in?

My guess is that the pins aren't making contact with the decoder socket. Are they noticably thinner on the MX617? Use a pair of pliers to put a slight kink in the pins could be enough to get your locos working.

Steven B

Offline Graham

  • Trade Count: (0)
  • Full Member
  • ***
  • N Gauge Society Number: 20459
  • Posts: 394
  • Country: au
  • Gender: Male
  • Modelling modern image
    • Awards
Re: MX617
« Reply #2 on: April 02, 2019, 09:35:52 AM »
Hi @Steven B, have put kinks in the pins as I found on the 622's it was required. I will try another loco type and manufacturer to see what happens there. The only thing I haven't tried is flipping the chip to see if the diagram on the packet is showing pin 1 in the wrong place. will try that tomorrow.
cheers
Graham

Offline Yet_Another

  • Trade Count: (+3)
  • Full Member
  • ***
  • N Gauge Society Number: 25847
  • Posts: 841
  • Country: gb
  • Gender: Male
  • Chacun son got!
    • Awards
Re: MX617
« Reply #3 on: April 02, 2019, 11:28:34 PM »
I installed three MX617Ns the other week with no problems (other than fitting one into a 64xx) - the diagram in the little leaflet identifies pin 1 correctly.
Tony

'...things are not done by those who sit down to count the cost of every thought and act.' - Sir Daniel Gooch of IKB

Offline Graham

  • Trade Count: (0)
  • Full Member
  • ***
  • N Gauge Society Number: 20459
  • Posts: 394
  • Country: au
  • Gender: Male
  • Modelling modern image
    • Awards
Re: MX617
« Reply #4 on: April 03, 2019, 04:42:44 AM »
thanks gents, I am pretty much convinced I have a bad batch. I tried putting the decoders into 2 other locos a 66 Farish and a 67 Dapol, with the same results. I then took a MX622 out of another loco and tested it in all the ones I have been working on and all worked fine. Still have a few from the shipment but will ring John at YouChoos tonight Melbourne time to discuss next course of action.

cheers
Graham

 

Please Support Us!
May Goal: £55.00
Due Date: May 31
Total Receipts: £55.00
Below Goal: £0.00
Site Currency: GBP
100% 
May Donations


Advertise Here
anything