N Gauge Forum

Notices, Help With Problems and Your Forum Ideas... => Forum Ideas and Problems. => Topic started by: Newportnobby on June 22, 2018, 08:51:45 PM

Title: Slow, slow, quick, quick, slow
Post by: Newportnobby on June 22, 2018, 08:51:45 PM
Is it just me or is the forum a bit 'all over the place' lately?
Normally it all churns over at a reasonable speed but all of a sudden in replying to a post or reading all unread posts and it just hangs for what seems ages.
Likewise, most of the time when I give a 'Thank You' it just hangs while 'Loading' is displayed at the top of the page. This often takes so long I abandon the 'Thank You' and just move on by pressing 'Home' and then reading the next unread post.
If it's just me then I'll shut up and suffer.
Title: Re: Slow, slow, quick, quick, slow
Post by: crewearpley40 on June 22, 2018, 08:53:37 PM
i have had the same issues, checked my connections, equipment, glad somebody else has noticed
Title: Re: Slow, slow, quick, quick, slow
Post by: port perran on June 22, 2018, 09:01:06 PM
I too have noticed the same.
Itís not too bad but just a bit of a niggle sometimes.
Title: Re: Slow, slow, quick, quick, slow
Post by: dannyboy on June 22, 2018, 09:18:45 PM
and it just hangs for what seems ages.


Unfortunately, that is normal for me, living where I do. The, (slightly better), internet connection at work is the only reason I work part-time and have not fully retired!  (Well, that and the money of course). ;D

And another reason why I am looking to return to blighty in the not too distant future.
Title: Re: Slow, slow, quick, quick, slow
Post by: njee20 on June 22, 2018, 09:20:17 PM
Yep, been a bit ropey here too!
Title: Re: Slow, slow, quick, quick, slow
Post by: Yet_Another on June 23, 2018, 10:37:21 AM
Yep, randomly hangs, irrespective of which connection Iím using
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on June 26, 2018, 04:22:24 PM
Is there anyone out there?
It's still going on.
Title: Re: Slow, slow, quick, quick, slow
Post by: Jerry Howlett on June 26, 2018, 06:53:49 PM
For me looking at unread posts brings up 6 or 7... I used to get 1999 pages or I may be exagerating a bit.
Title: Re: Slow, slow, quick, quick, slow
Post by: Caz on June 26, 2018, 06:57:32 PM
Probably talking this up but not having any problems here in Spain.   :P
Title: Re: Slow, slow, quick, quick, slow
Post by: Only Me on June 26, 2018, 07:02:25 PM
And back to quick quick quick...
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on June 26, 2018, 07:34:56 PM
And back to quick quick quick...

Keep sticking those new quid coins in the meter please
Title: Re: Slow, slow, quick, quick, slow
Post by: Yet_Another on June 26, 2018, 09:20:20 PM
No, no, slow, slow!

Just wouldn't load one particular page.
Title: Re: Slow, slow, quick, quick, slow
Post by: Bealman on June 26, 2018, 11:57:18 PM
Is there anyone out there?
It's still going on.

Yeah, I'm still here, Mick, but didn't want to say anything that might upset you cos there's no problems here  :P
Title: Re: Slow, slow, quick, quick, slow
Post by: port perran on June 27, 2018, 03:09:28 PM
Just after 3pm today and itís slow, slow, almost stopped, slow Iím afraid.
Title: Re: Slow, slow, quick, quick, slow
Post by: Only Me on June 27, 2018, 03:52:37 PM
it's been fine all day, I can see from the stats.... probably your isp overheating :D
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on July 02, 2018, 10:07:38 AM
And back to quick quick quick...

Nope :no:
Surprised it hasn't 'timed out' this morning
Title: Re: Slow, slow, quick, quick, slow
Post by: Only Me on July 02, 2018, 10:13:46 AM
And back to quick quick quick...

Nope :no:
Surprised it hasn't 'timed out' this morning

Mick, it sounds like your antiquated it stack, theres no problems this end.... maybe time to buy a new pc or change your broadband supplier
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on July 02, 2018, 10:22:01 AM
It's totally inconsistent. One minute it's racing along and then, for one or two posts or replies, it just hangs. Then it's off again like a good 'un. I don't have any such issues with other websites.
I agree BT Infinity speeds are not the best they could be in my area but they are the best of a bad lot. I won't contemplate a smart phone as reception in this area is  :censored:awful on all networks so my prehistoric mobile doesn't even work at home ::) (Mind you, my last company supplied me with a mobile phone which didn't work at their premises :doh:)

Maybe your solution is that I move home. Happy to do so if you care to underwrite my mortgage :P ;)
Title: Re: Slow, slow, quick, quick, slow
Post by: Fardap on July 02, 2018, 10:34:40 AM
I had noticed it being slow the other day, everything else on the web was fine but it was slow to respond; restarted browser etc. still sluggish.

Today it is zipping along though.
Title: Re: Slow, slow, quick, quick, slow
Post by: Bealman on July 02, 2018, 10:40:47 AM
Continues to be OK here.

Ah well, if you're going to move, Mick, it's only one more long haul to Australia  >:D :beers:
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on July 02, 2018, 10:51:47 AM
Ah well, if you're going to move, Mick, it's only one more long haul to Australia

But I haven't done anything wrong! Honest, Guv, it wasn't me :no: :P
Title: Re: Slow, slow, quick, quick, slow
Post by: Bealman on July 02, 2018, 10:55:12 AM
Bring a load of bread with ya.

We're a bit short here in the colonies  ;)
Title: Re: Slow, slow, quick, quick, slow
Post by: Only Me on July 02, 2018, 11:08:38 AM
Maybe your solution is that I move home. Happy to do so if you care to underwrite my mortgage :P ;)


So when you hit the site your request gets directed through one of the hosting companies load balancers, generally they are fast, but if you live in the North, it has to go through the one near Whitby, which unfortunately at the moment is facing staffing issues due to Daphne being on her holidays in Skegness and her colleague Mabel having to do all the data entering on her own, usually Mabel would read your requests and Daphne would patch you through to the correct place, but at the moment the poor old Duck is having to do it all herself.

(http://attic.areavoices.com/files/2011/10/phone2.jpg)

I've just called to advise your annoyance, so they are sending Sid across the big hill from Leeds assist..... he reckons with a good wind and this great weather he should be there by Thursday..

(http://oldblokeonabike.com/wp-content/uploads/2011/07/ron2.jpg)

Title: Re: Slow, slow, quick, quick, slow
Post by: Bealman on July 02, 2018, 11:20:18 AM
Is that you  ;)
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on July 02, 2018, 03:47:56 PM
Is that you  ;)


No. My bike doesn't have that many cylinders :(

@Only Me (http://www.ngaugeforum.co.uk/SMFN/index.php?action=profile;u=1328)
Very good. Helpful as an ashtray on a motorbike, but very good.
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on July 05, 2018, 02:08:43 PM
Just clicked on 'Mark all messages as read' and waited, and waited, and waited and  :doh:

(http://www.ngaugeforum.co.uk/SMFN/gallery/67/264-040718132202-671891766.jpeg)
Title: Re: Slow, slow, quick, quick, slow
Post by: Only Me on July 05, 2018, 02:31:48 PM
Mick, its fine here so can only assume the issue is with your machine not refreshing  or your broadband
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on July 05, 2018, 02:47:20 PM
Now where have I heard that before? :hmmm:
No issues with other sites, like I say
Title: Re: Slow, slow, quick, quick, slow
Post by: Yet_Another on July 05, 2018, 06:39:35 PM
Iím with you, NPN. The database queries that build the pages are fine, but every so often there is no response until *stop* & *refresh* are hit, when normal service is resumed. This is platform & provider agnostic. Apple/Windows/ mobile/landline.
Title: Re: Slow, slow, quick, quick, slow
Post by: Tank on July 05, 2018, 08:01:19 PM
Not had any problems all day from this end.
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on July 05, 2018, 09:29:45 PM
Looks like it's me wearing it out :laugh3:
Title: Re: Slow, slow, quick, quick, slow
Post by: Tank on July 05, 2018, 09:59:22 PM
It must your post count!   :jawdropping:
Title: Re: Slow, slow, quick, quick, slow
Post by: Bealman on July 05, 2018, 10:41:48 PM
 :laughabovepost: :laughabovepost: :smiley-laughing:
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on July 05, 2018, 10:43:53 PM
It must your post count!   :jawdropping:

If each post was a mile then I have more than circumnavigated the earth :)
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on November 12, 2018, 10:33:25 AM
You're probably as tired of reading this as I am in typing it but there's just no rhyme or reason to it.
One minute the forum speed is tazzing along and then, for no apparent reason, someone puts the brakes on. Read a post, press 'Home', click on 'Read all unread posts' and then go make a coffee while it loads ::) Every time I try to give a 'Thank You' the page just hangs with a bar at the top saying 'Loading.....'. Sometime the page even goes blank while it thinks about whether to show anything or not. Grrrrrr.

Mick, its fine here so can only assume the issue is with your machine not refreshing  or your broadband

And before this old hackneyed thing gets trotted out again I have no issues with my e mail system, model shop sites, BBC weather or the Kawasaki Club forum etc :P
Title: Re: Slow, slow, quick, quick, slow
Post by: Only Me on November 12, 2018, 10:58:31 AM
You need to be waring the foil hat with the ariel mick
Title: Re: Slow, slow, quick, quick, slow
Post by: Bob Tidbury on November 12, 2018, 11:22:20 AM
No problem here in High Wycombe ,it was a bit slow on Friday in Ipswich but that I think was down to the internet at the Premier Inn ,we couldnít even get either of our phones to work on O2 or T-Mobile lady on the desk said itís a very up and down signal for phones .
Bob Tidbury
Title: Re: Slow, slow, quick, quick, slow
Post by: MalcolmInN on November 12, 2018, 12:59:04 PM
You're probably as tired of reading this as I am in typing it

I have no issues with my e mail system, model shop sites, BBC weather or the Kawasaki Club forum etc
The interwebby can be very frustrating , sorry to hear that your problems are persisting !
Perhaps your other sites dont have as much traffic to shift ! <no no  not really, just a feeble attempt at a joke :)
That would suggest a problem with Ngauge, but if we (the rest of us) are not seeing it it would suggest that it is not !!!!
Weird, needs some more digging I think, for example :--

When one of these hiatuses (hiatii ?) happens have you done a generalised speed test, (Google "Speed test", many are available, take an average of them )
http://www.supportal-test.co.uk/ (http://www.supportal-test.co.uk/) seems to be consistent and is the one my ISP uses to problem solve.
It would at least give a more stable idea of traffic to shift.

Now we get a bit geekish :---
Those speed sites will also give you a MS reading (millisecond response time to its chosen test site) note it during the good times and bad.

Do you know how to raise a cmd prompt ?*
Then do a ping test to the Ngauge server*. and compare it with the general speed result and also with when Ngauge is performing ok.

* * I wont go on at length just now, if you want more (like how to find the Ngauge IP to ping) I can do, but also I am sure our boffins will be able to advise you at length better.

Title: Re: Slow, slow, quick, quick, slow
Post by: MalcolmInN on November 12, 2018, 01:06:31 PM
PS I should have attached this, currently Ngauge is showing 24ms, which is pdq :) ( I think, what do others see ? )


C:\>ping 94.126.40.39

Pinging 94.126.40.39 with 32 bytes of data:
Reply from 94.126.40.39: bytes=32 time=24ms TTL=53
Reply from 94.126.40.39: bytes=32 time=24ms TTL=53
Reply from 94.126.40.39: bytes=32 time=25ms TTL=53
Reply from 94.126.40.39: bytes=32 time=25ms TTL=53

Ping statistics for 94.126.40.39:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 24ms, Maximum = 25ms, Average = 24ms
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on November 12, 2018, 04:11:02 PM
You completely lost me after the first 'The.......', Malcolm.
My speed on BT Infinity fibre optic is not great but other sites don't seem to be affected and I'd expect them to be if it was a general thing. Likewise when kids get home from school is not a particularly good time to be surfing. I don't feel like paying BT any more to upgrade, though. :no:
Title: Re: Slow, slow, quick, quick, slow
Post by: MalcolmInN on November 12, 2018, 08:07:08 PM
You completely lost me after the first 'The.......'
I dont know how to follow that then !

I was trying to determine if anything else changes when the forum fails,,,,  to narrow down some avenues to explore you see :(

Sorry I couldnt help.
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on November 12, 2018, 09:50:10 PM
@MalcolmInN (http://www.ngaugeforum.co.uk/SMFN/index.php?action=profile;u=3699)
Using your OOkia speed test I get 24.1mbps upload and 8.4mbps download with an ms of 14.
This is as much gibberish to me as electrickery is :dunce:
Title: Re: Slow, slow, quick, quick, slow
Post by: MalcolmInN on November 12, 2018, 10:54:44 PM
Ok so far so good, (except I think you have reversed the up and down ! :) )
and now you know more than me cos I dint realise that "my" one is also hosted by Ookla !! :) Yes Ookla, in its normal guise, is quite consistent.

All we need to do now is wait for the forum to go wrong on you and then you do it all again and see if owt changes in those numbers.

paying BT any more to upgrade, though. :no:
If it is any help :
(a) 24 Mbs is more than good enough for surfing and foruming so no need to up the BT fibre ante for that.
I have not got infinity fibre and my 5.5 is good enough.
(b) 13ms is better than mine (24 see earlier, of which ~20 is just to reach my ISP !) so no probs there either.

This is as much gibberish to me as electrickery is :dunce:
but you can use a switch to turn the lights on ! Same deal with the interwebby, look at you you did a speed test ! Almost a geek already  ;D
Title: Re: Slow, slow, quick, quick, slow
Post by: Malc on November 12, 2018, 10:58:36 PM
I must admit that the forum speed is very variable. I sometimes get a very slow response when posting or selecting ďshow unread postsĒ. My network speed is generally about 120Mbytes download speed.
Title: Re: Slow, slow, quick, quick, slow
Post by: MalcolmInN on November 12, 2018, 11:15:15 PM
get a very slow response when posting or selecting “show unread posts”.
At those times what does Traceroute show ?  C:\>tracert 94.126.40.39

I was petrified of suggesting that to NPR after his reaction to the rest of my gibberish !
Title: Re: Slow, slow, quick, quick, slow
Post by: Shropshire Lad on November 13, 2018, 09:56:38 AM
It's definitely the forum Mick. My router monitors the incoming broadband speed and the WiFi mesh signal neither of which change dramatically. Worth the occasional hesitancy once you realise you haven't got a problem with your kit 😀
Title: Re: Slow, slow, quick, quick, slow
Post by: Malc on November 13, 2018, 06:23:57 PM
Unfortunately Malcolm, I use an iPad usually and not a PC. Next time I notice a slowing down, iíll Nip up to my office and check.
Title: Re: Slow, slow, quick, quick, slow
Post by: Lawrence on November 13, 2018, 08:24:26 PM
I gave up around 08:30 this morning, forum just wouldn't load
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on November 13, 2018, 10:24:20 PM
What brasses me off is when I think to myself "I have an hour to spare before I go out so I'll get on the forum" and then find it so slow I accomplish nothing before I have to depart ::)
Title: Re: Slow, slow, quick, quick, slow
Post by: Bealman on November 13, 2018, 11:09:27 PM
No problems here but then I am upside down
Title: Re: Slow, slow, quick, quick, slow
Post by: Only Me on November 13, 2018, 11:49:09 PM
Every time this pops up i check and cant find an issue, somaybe it is the geographical region however more likely the isp or the area
Title: Re: Slow, slow, quick, quick, slow
Post by: dannyboy on November 14, 2018, 08:47:56 AM
Not exactly the same problem, but for some notifications of posts, it is taking ages for the notification to get to me. As an example, the notification of the above post by NPN timed at 10.24pm. was received by me at 2225. Yet the notification of the post prior to NPN, by Lawrence, timed at 8.24pm, was not received by me until 2355!  ???. This happens regularly, i.e. posts taking an hour or two to be notified to me, or being received out of sequence. It is not a big problem, but a bit annoying when I follow a link in a notification only to find it is a post I have already read. I know I am not the only one experiencing this problem, Daffy also had the problem. (25th October). I also remarked on this problem back in July.
Title: Re: Slow, slow, quick, quick, slow
Post by: Bealman on November 14, 2018, 09:27:47 AM
I think that the way members use the forum is a factor, too.

Here in Australia, I am going to bed when forum activity becomes heavy. When I wake up, I have multiple email notifications from the forum.

I delete them all from my emails!

I know that when I get on the forum, I'll see them all anyway!
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on November 14, 2018, 12:51:21 PM
Every time this pops up i check and cant find an issue, somaybe it is the geographical region however more likely the isp or the area


And as I keep saying I have no issues with any other website so maybe the geographical region or isp doesn't like the forum. I would perhaps agree if I had issues elsewhere but I don't. How about @Lawrence (http://www.ngaugeforum.co.uk/SMFN/index.php?action=profile;u=16) ?
Title: Re: Slow, slow, quick, quick, slow
Post by: Lawrence on November 14, 2018, 01:32:54 PM
Every time this pops up i check and cant find an issue, somaybe it is the geographical region however more likely the isp or the area


And as I keep saying I have no issues with any other website so maybe the geographical region or isp doesn't like the forum. I would perhaps agree if I had issues elsewhere but I don't. How about @Lawrence ([url]http://www.ngaugeforum.co.uk/SMFN/index.php?action=profile;u=16[/url]) ?


I was at work (Dundee) yesterday when it was so slow I gave up, at home (Fife) it can be really hit and miss and there seems no rhyme or reason for it. I would expect some drop in bandwidth in the evenings when folks are home streaming stuff etc but we have (up to) 36mB fibre now and have no issues at all, in all honesty, in the evening we probably have 2 phones, 2 tablets a laptop and SWMBO streaming on the TV all connected no issues, then if I go on the forum it is a bit of a lottery. As others have said, not really noticed problems with other sites.
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on November 15, 2018, 01:17:09 PM
Strangely since I last moaned there has been excellent speed on the forum so I can only assume @Only Me (http://www.ngaugeforum.co.uk/SMFN/index.php?action=profile;u=1328) has put another thrupenny bit in the meter :D
Title: Re: Slow, slow, quick, quick, slow
Post by: Only Me on November 15, 2018, 01:47:18 PM
Al i did was untag myself from this thread to stop the spam and voila it fixed itself...

;)
Title: Re: Slow, slow, quick, quick, slow
Post by: Yet_Another on November 20, 2018, 09:08:15 PM
If only it were so.

A bit like wading through treacle this evening.
Title: Re: Slow, slow, quick, quick, slow
Post by: Newportnobby on November 20, 2018, 09:54:14 PM
I can only assume @Only Me ([url]http://www.ngaugeforum.co.uk/SMFN/index.php?action=profile;u=1328[/url]) has put another thrupenny bit in the meter :D


Just goes to show thruppence goes nowhere nowadays ::)
Title: Re: Slow, slow, quick, quick, slow
Post by: Lawrence on November 21, 2018, 09:22:11 PM
I don't want to be an arse about this but someone has to ask, what is being done to resolve these issues?
Many of us have experienced the wading through treacle accessibility issues as mentioned earlier, and more frequently, so what needs to be done to fix it? Do we need greater financing to provide a better server/greater bandwidth? Do we need to move to a new format because SMF can't handle the membership/traffic in this format.
 
Title: Re: Slow, slow, quick, quick, slow
Post by: MacRat on November 22, 2018, 06:39:24 PM
Today about 15h German time, I experienced a slight hesitance of the forum to load and put the forum start page into a web performance tester https://www.webpagetest.org/ (https://www.webpagetest.org/) with the default settings.

https://www.webpagetest.org/result/181122_M6_ac6426a8f2dc7784e98b4370a8ba0411/ (https://www.webpagetest.org/result/181122_M6_ac6426a8f2dc7784e98b4370a8ba0411/)
The fully loaded time was 8 seconds. After DNS and connection the html loading took 3.2 seconds for the first byte to load.

The current test about 19h German time, with the same test settings, took only 0.6 seconds for the first byte and fully loaded in about 4 seconds. https://www.webpagetest.org/result/181122_CG_ce72a620ab0a025360f2630bb1836b76/ (https://www.webpagetest.org/result/181122_CG_ce72a620ab0a025360f2630bb1836b76/)
All subsequent requests for the images are all about 100ms to 200ms faster, than the first test.

As the same test server was used, and the DNS and connection times are comparable, I would conclude that there is evidence that the speed of the actual serving of the forum content is different in the range of seconds. However, this does not automatically mean the forum software itself has an issue. Maybe the hosting company is just running other things on the same machine.

As a sidenote, I found it interesting, that the forum start page is 88.8% images and only 2% html, i.e. content.