N Gauge Forum

Notices, Help With Problems and Your Forum Ideas... => Computer Help => Topic started by: Innovationgame on February 23, 2018, 02:35:17 PM

Title: JMRI not working
Post by: Innovationgame on February 23, 2018, 02:35:17 PM
 :helpneededsign: I have installed JMRI and I wanted to make a start so that when I get a laptop, I will be able to transfer the files and get things moving.  I have been able to enter the layout editor and create a schematic of my layout, including all the loops and turnouts.  However, when I try to access any table, all that happens is that a hidden blank window is created.  The editor and PanelPro still work at this stage.  However, if I open the window via the PanelPro Window menu item, everything stops working.  I cannot even close PanelPro.  I have to resort to Taskmanager to end the Java Process. I went to the JMRI discussion forum on SouorceForge.net, but I need to register to use that.  I have tried to register with SourceForge, but I get no reply, so I am stuck.  Does anyone have any ideas?
Title: Re: JMRI not working
Post by: ntpntpntp on February 23, 2018, 03:40:21 PM
I've not been there for a while, but I used to use the JMRI Yahoo group.

It will be handy if you post  some detail of your PC operating system, version of JMRI you installed and the java version it's running on (from memory I think JMRI has a Help>About box on its main menu that will tell you useful stuff)
Title: Re: JMRI not working
Post by: Snowwolflair on February 23, 2018, 04:28:16 PM
:helpneededsign: I have installed JMRI and I wanted to make a start so that when I get a laptop, I will be able to transfer the files and get things moving.  I have been able to enter the layout editor and create a schematic of my layout, including all the loops and turnouts.  However, when I try to access any table, all that happens is that a hidden blank window is created.  The editor and PanelPro still work at this stage.  However, if I open the window via the PanelPro Window menu item, everything stops working.  I cannot even close PanelPro.  I have to resort to Taskmanager to end the Java Process. I went to the JMRI discussion forum on SouorceForge.net, but I need to register to use that.  I have tried to register with SourceForge, but I get no reply, so I am stuck.  Does anyone have any ideas?

Check you have the correct version of JAVA installed.  This is usually what causes problems.
Title: Re: JMRI not working
Post by: Innovationgame on February 23, 2018, 04:57:20 PM
Thanks for the help.  I eventually got some help from JMRI and the issue was a sound file bug in the official release.  I have now installed Test Version 4.11.3 and that has solved the problem.
Title: Re: JMRI not working
Post by: njee20 on February 23, 2018, 07:43:48 PM
Yes, I had the same issue, only present in the latest stable release, but as you've found installing the latest test release sorts it!
SimplePortal 2.3.5 © 2008-2012, SimplePortal